First time here? Checkout the FAQ!
x
+1 vote
by (160 points)

Hello,

After downloading the latest package (11.26.2020 17:22 32M) and running the installer, the process crashed. I have macOS Catalina v 10.15 and Xcode v 12.2 

Thank you 

2 Answers

0 votes
by (210 points)
Thanks for the report, Patricia.

I can confirm this issue for today's latest pkg, but also the 4.0 pkg. I'm on Catalina 10.15.7 with XCode 12.2 and Python 3.8.5. Installing v3.2 works, however.

Unfortunately, Patricia, I don't currently have any advice for you. You could - for now - install the older version 3.2. For 4.0 and latest, I think we need to fix the issue in the package.

Note for others: I also tried uninstalling first, as well as partial install (without carputils) but both fail as well.

Technical details: I have tracked the issue to the 'postinstall' scripts. I will create an issue in with all the info I found.
0 votes
by (210 points)
Dear Patricia,

it seems like the newest version of the installer works on Catalina again :)

Please give it a try!

Best wishes

Eike
by (160 points)
Dear Eike,

Thanks for your reply. I tried installing the latest version but unfortunately, the installer gets stuck. The same happened even after restarting my computer and launching the installer again.

Thank you for your kind support.

Sincerely,

Patricia
by (210 points)
Dear Patricia,

oh, that is unfortunate. Can I just confirm, your macOS version is still 10.15 (Catalina) and you have Python 3 installed as well?

Best,
Eike
by (160 points)
Yes, I have double-checked and I still have Catalina 10.15.7 and Python 3 installed.

Thanks for your support!

Best wishes,

Patricia
by (210 points)
Hi Patricia,

thanks for the report, we also found the issue and are working on it. The installer probably gets stuck when calling pip to install python packages which required compilation.

Would you mind providing the installation log to me (yung-lin.huang@universitaets-herzzentrum.de) for better identifying the issue? The log info is record at "/var/log/install.log" when running the installer. Thank you.
by (160 points)
Hi Yung-Lin,

I have sent you the install.log to your email.

Many Thanks.

Sincerely,

Patricia
Welcome to openCARP Q&A. Ask questions and receive answers from other members of the community. For best support, please use appropriate TAGS!
architecture, carputils, documentation, experiments, installation-containers-packages, limpet, slimfem, website, governance
...