First time here? Checkout the FAQ!
0 votes
by (350 points)


I have installed meshalyzer and I can execute it using ./Meshalyzer-3.2-x86_64.AppImage

The problem is when I try opening something in meshalyzer.The tab widget is there, but as soon as it opens I start getting the following error:


error: linking with uncompiled/unspecialized shadererror: linking with uncompiled/unspecialized shader


0:1(10): error: GLSL 4.10 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, 1.00 ES, and 3.00 ES


0:1(10): error: GLSL 4.10 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, 1.00 ES, and 3.00 ES


I tried: sudo apt-get upgrade mesa-common-dev libgl1-mesa-dev libglu1-mesa-dev and MESA_GL_VERSION_OVERRIDE=4.1 but it didn't work.

How can I solve this problem?

Thanks :)

by (3.4k points)

On which operating system are you? Are you using the Windows Subsystem for Linux ?
by (350 points)
Yes, I'm using a subsystem. Kali to be specific, it is very similar to ubuntu

2 Answers

+1 vote
by (3.4k points)


I installed Kali Linux in WSL and managed to make Meshalyzer work. The idea is the same as the one I proposed above, but some more operations have to be done in order to use the ppa on Kali Linux (remember that this ppa is not official, you would then use it at your own risks).

  • First, add the following lines to `/etc/apt/sources.list`:

Please note that 'focal' corresponds to the matching Ubuntu version, it could change with future releases of Kali Linux.

  • By running `sudo apt update`, you should then run into this error:

 W: GPG error: focal InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY F63F0F2B90935439

(The characters at the end could differ)

You should then run the following commands (replace the key number by the one displayed in your error message):

gpg --keyserver hkp:// --recv F63F0F2B90935439
gpg --export --armor  F63F0F2B90935439 | sudo apt-key add -
  • You can now run `sudo apt update` and `sudo apt upgrade`

I was then able to run Meshalyzer examples.

by (350 points)
Hi! I tried doing this and the process went fine, but when I try to execute the examples I still get the previous mistake, where meshalyzer opens but in a blank screen and nothing in the Meshalyzer controls work. I will try downloading everything again in a different machine to see if it solves the issue.
Anyways, thanks a lot!
0 votes
by (3.4k points)

You could try to get the latest drivers from an alternative (non official) repository. It worked for me on Ubuntu in WSL:

add-apt-repository ppa:oibaf/graphics-drivers 

apt update

apt upgrade

by (350 points)
It didn't work for me :(
Using the command glxinfo -B I got the following information:

name of display: :1.0
display: :1  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: Mesa/ (0xffffffff)
    Device: llvmpipe (LLVM 12.0.1, 256 bits) (0xffffffff)
    Version: 21.2.6
    Accelerated: no
    Video memory: 4647MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
OpenGL vendor string: Mesa/
OpenGL renderer string: llvmpipe (LLVM 12.0.1, 256 bits)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 21.2.6
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 21.2.6
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 21.2.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

But the error I'm getting says it doesn't suport GLSL 4.10... I'm a bit confused.

Also I found that you can use apt-get install to download a specific version of a package, for example: sudo apt-get install apache2=2.2.20-1ubuntu1
I believe this might be helpful somehow, but it doesn't recognize GLSL as a valid package... any thoughts?
by (3.4k points)
If I understand it correctly, your OpenGL version string is 3.1 and should be at least 4.10.
First of all, you could try to update and upgrade your packages from `ppa:oibaf/graphics-drivers` again, since a new version of mesa (v22) was released since then.

Otherwise, I will have to reproduce your environment to investigate more (this afternoon hopefully).
by (570 points)
I think that it is the other way round. Meshalyzer does not support the version 4.10 but the older ones.

However you can use the `export MESA_GL_VERSION_OVERRIDE=4.1` command to setup an environment variable in your shell to ignore this problem.

The issue is also reported in
Welcome to openCARP Q&A. Ask questions and receive answers from other members of the community. For best support, please use appropriate TAGS!
architecture, carputils, documentation, experiments, installation-containers-packages, limpet, slimfem, website, governance