First time here? Checkout the FAQ!
x
0 votes
by (230 points)
ehsan@HHU:~/meshalyzer$ make

...

[ 62%] Linking CXX executable meshalyzer
/usr/bin/ld: CMakeFiles/meshalyzer.dir/trimesh.cxx.o: in function `Controls::Controls()':
trimesh.cxx:(.text+0x80d0): undefined reference to `CS_Choice::CS_Choice(int, int, int, int, char const*)'
/usr/bin/ld: trimesh.cxx:(.text+0x890d): undefined reference to `CS_Choice::CS_Choice(int, int, int, int, char const*)'
/usr/bin/ld: trimesh.cxx:(.text+0xa4c6): undefined reference to `CS_Choice::CS_Choice(int, int, int, int, char const*)'
/usr/bin/ld: CMakeFiles/meshalyzer.dir/trimesh.cxx.o: in function `Controls::restore_state(std::istream&)':
trimesh.cxx:(.text+0xecfa): undefined reference to `CS_Choice::value(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)'
/usr/bin/ld: trimesh.cxx:(.text+0xfdec): undefined reference to `CS_Choice::value(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)'
/usr/bin/ld: trimesh.cxx:(.text+0x100b5): undefined reference to `CS_Choice::value(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)'
/usr/bin/ld: CMakeFiles/meshalyzer.dir/trimesh.cxx.o: in function `Controls::save_state(std::ostream&, bool)':
trimesh.cxx:(.text+0x12f9e): undefined reference to `CS_Choice::value[abi:cxx11]()'
/usr/bin/ld: trimesh.cxx:(.text+0x13c32): undefined reference to `CS_Choice::value[abi:cxx11]()'
/usr/bin/ld: trimesh.cxx:(.text+0x1474b): undefined reference to `CS_Choice::value[abi:cxx11]()'
collect2: error: ld returned 1 exit status
make[2]: *** [src/CMakeFiles/meshalyzer.dir/build.make:1048: src/meshalyzer] Error 1
make[1]: *** [CMakeFiles/Makefile2:127: src/CMakeFiles/meshalyzer.dir/all] Error 2
make: *** [Makefile:156: all] Error 2

do you have any idea where could be the problem?

thanks!

Ehsan
by (2.4k points)
Does this problem still occur with the latest code in the master branch?

If so, please open an issue here: https://git.opencarp.org/openCARP/meshalyzer/-/issues
by (230 points)
It works now. I guess here was the graphic driver too ...

1 Answer

0 votes
by (2.4k points)
 
Best answer
Solved - see comment above.
Welcome to openCARP Q&A. Ask questions and receive answers from other members of the community. For best support, please use appropriate TAGS!
architecture, carputils, documentation, experiments, installation-containers-packages, limpet, slimfem, website, governance
...