First time here? Checkout the FAQ!
x
0 votes
by (310 points)

Hi

This question is very similar to "Ionic Model mMS not working". I try to use BO model by adding [-imp_region[0].im', 'BO'] to the command. Doing this, I get the error message:

Assigning IMPS to tagged regions:
L5 : Illegal IM specified: BO.

I tried adding values for all the parameters, since default is None for almost all parameters in the implementation of this model, but this did not help either.

In addition to that, I also pulled carputils again and rebuild openCARP.

What am I doing wrong?

Kind Regards

Lore

1 Answer

+1 vote
by (1.4k points)

Hi!

I assume the BO model was generated by you, as it is not part of the models included in openCARP.

If you have already built a BO.so shared object, you can load your model via the options:

-num_external_imp 1
-external_imp[0] "/absolute/path/to/BO.so"

With this options, you should be able to use

-imp_region[0].im BO

Hope it works, Aurel

by (310 points)
Hi Aurel

Thank you for the quick reply!

I was under the assumption that it was part of the models included in  openCARP since I found it in the code documentation of carputils under carputils.model.ionic.BOIonicModel. It is the third one in the list shown there.
by (1.4k points)
Hi!

CARPutils is used across multiple simulators from the CARP family. As such, not all models referenced in CARPutils may be part of openCARP.

The general way to check which models are compiled into openCARP, is to call

opencarp/bin/bench.* --list-imp

Cheers, Aurel
by (310 points)
This is helpful! Thank you!
Welcome to openCARP Q&A. Ask questions and receive answers from other members of the community. For best support, please use appropriate TAGS!
architecture, carputils, documentation, experiments, installation-containers-packages, limpet, slimfem, website, governance
...